Fedora Linux Support Community & Resources Center
  #1  
Old 4th September 2013, 11:26 AM
machinegodzilla Offline
Registered User
 
Join Date: Jan 2012
Location: United Kiingdom
Posts: 10
linuxfirefox
Question System time changes every time I restart the machine.

Hi,


I have Fedora release 18 (Spherical Cow) 3.9.4-200.fc18.x86_64 with XFCE 4.10. Every time I restart the computer the time changes by one hour forward. For example it is

Quote:
Wed, 04 Sep 2013 10:18:22 +0100
instead of:

Quote:
Wed, 04 Sep 2013 9:18:22 +0100
I then correct it with:

Quote:
sudo date --set="Wed, 04 Sep 2013 9:18:22 +0100"
but after the reboot it reverts to the incorrect setting.

The time in the BIOS is correct. My locale is correct too:

Quote:
LANG=en_GB.UTF-8
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=
I don't have ntpd running:

Quote:
$ service ntpd status
Redirecting to /bin/systemctl status ntpd.service
ntpd.service - Network Time Service
Loaded: loaded (/usr/lib/systemd/system/ntpd.service; disabled)
Active: inactive (dead)
How do I go about troubleshooting such problem?
Reply With Quote
  #2  
Old 4th September 2013, 11:57 AM
kldixon Offline
Registered User
 
Join Date: Aug 2005
Posts: 490
linuxfirefox
Re: System time changes every time I restart the machine.

Presumably, something thinks the real time clock is set to GMT. I am using F19 GNOME with network time so cannot check directly. Did you select clock is GMT at install time?
Reply With Quote
  #3  
Old 4th September 2013, 12:17 PM
kldixon Offline
Registered User
 
Join Date: Aug 2005
Posts: 490
linuxfirefox
Re: System time changes every time I restart the machine.

Sorry, for GMT read UTC (much the same thing in this context). A quick look at the installation guides implies the option was removed between f17 and f18 and I have a vague memory of that. Windows would always use the real time clock and reset it at daylight saving events so one had the option of taking the time from it verbatim in the case of dual booting or setting it to UTC if one only had Linux installed. There may be an option under XFCE to select between the two cases.
Reply With Quote
  #4  
Old 4th September 2013, 01:49 PM
machinegodzilla Offline
Registered User
 
Join Date: Jan 2012
Location: United Kiingdom
Posts: 10
linuxfirefox
Re: System time changes every time I restart the machine.

I have not idea what I selected at the installation time.

Quote:
Originally Posted by kldixon View Post
Presumably, something thinks the real time clock is set to GMT.
Yes, I'm after that something :-)


I copied this question over to XFCE forum, two heads are better than one :-)
Reply With Quote
  #5  
Old 4th September 2013, 03:38 PM
kldixon Offline
Registered User
 
Join Date: Aug 2005
Posts: 490
linuxfirefox
Re: System time changes every time I restart the machine.

This may help:
https://wiki.archlinux.org/index.php/Time
Time, like everything else, is now in the domain of systemd. Perhaps XFCE has not yet submitted.
Reply With Quote
  #6  
Old 4th September 2013, 04:00 PM
machinegodzilla Offline
Registered User
 
Join Date: Jan 2012
Location: United Kiingdom
Posts: 10
linuxfirefox
Re: System time changes every time I restart the machine.

Ha! So it wasn't linux, it wasn't xfce, it was windows messing with the hardware clock and yes I'm on a dual boot system. I didn't quite get your comment about the "real time clock" at first and was thinking why you mentioned windows at all. I was also thinking how come BIOS knew without any locale settings about the daylight saving time.

It's all clear now. Unchecking "System clock uses UTC" worked and now it's time to sort out the windows settings.

Thank you for your help!
Reply With Quote
  #7  
Old 8th October 2013, 07:13 AM
Al K D Fedora Offline
Registered User
 
Join Date: Oct 2012
Location: Australia
Posts: 5
linuxfirefox
Smile Re: System time changes every time I restart the machine.

I have multi-boot on Fedora 19, Fedora 18, Fedora 17 and Windows 7. Every time I booted up Fedora 19, the time changes. Each time I changes Settings->Date &Time->Network time ON and set the local time, the time changes back to UTC on every reboot to Fedora 19. Up to Fedora 18, I never had the problem as it always sync with the NTP time as my router is also NTP enabled.

I looked into the forum and decided on the following.


$ sudo yum install ntpdate

$ sudo systemctl enable ntpdate.service

$ sudo systemctl status ntpdate.service

$ sudo systemctl start ntpdate.service

$ sudo systemctl status ntpdate.service

$ sudo yum install ntp

$ sudo systemctl enable ntpd.service

$ sudo systemctl status ntpd.service

$ sudo systemctl start ntpd.service

$ sudo systemctl status ntpd.service


I checked on the status, and for a long time, it is finally working. I also checked on Settings->Date &Time->Network time and on reboot it is finally ON.

Those at Fedora or proclaimed to be in the Fedora ecosystem who are responsible for time synchronisation had failed. The TIME issue must be address in the next release. What is the point of pushing out a new package that did not work!
Reply With Quote
  #8  
Old 8th October 2013, 11:22 AM
machinegodzilla Offline
Registered User
 
Join Date: Jan 2012
Location: United Kiingdom
Posts: 10
linuxfirefox
Re: System time changes every time I restart the machine.

If you think this is a genuine bug then file a bug report.
Reply With Quote
  #9  
Old 8th October 2013, 12:40 PM
kldixon Offline
Registered User
 
Join Date: Aug 2005
Posts: 490
linuxfirefox
Re: System time changes every time I restart the machine.

Fedora 19 uses chrony and it works fine here:
Code:
$ timedatectl status
      Local time: Tue 2013-10-08 11:21:22 BST
  Universal time: Tue 2013-10-08 10:21:22 UTC
        Timezone: Europe/London (BST, +0100)
     NTP enabled: yes
NTP synchronized: yes
 RTC in local TZ: no
      DST active: yes
 Last DST change: DST began at
                  Sun 2013-03-31 00:59:59 GMT
                  Sun 2013-03-31 02:00:00 BST
 Next DST change: DST ends (the clock jumps one hour backwards) at
                  Sun 2013-10-27 01:59:59 BST
                  Sun 2013-10-27 01:00:00 GMT

# systemctl status chronyd
chronyd.service - NTP client/server
   Loaded: loaded (/usr/lib/systemd/system/chronyd.service; enabled)
   Active: active (running) since Tue 2013-10-08 07:36:17 BST; 3h 58min ago
  Process: 853 ExecStartPost=/usr/libexec/chrony-helper add-dhclient-servers (code=exited, status=0/SUCCESS)
  Process: 382 ExecStart=/usr/sbin/chronyd -u chrony $OPTIONS (code=exited, status=0/SUCCESS)
 Main PID: 391 (chronyd)
   CGroup: name=systemd:/system/chronyd.service
           └─391 /usr/sbin/chronyd -u chrony

Oct 08 07:36:06 computer2 chronyd[391]: chronyd version 1.29 starting
Oct 08 07:36:06 computer2 chronyd[391]: Linux kernel major=3 minor=11 patch=3
Oct 08 07:36:06 computer2 chronyd[391]: hz=100 shift_hz=7 freq_scale=1.00000...2
Oct 08 07:36:17 computer2 chronyd[391]: Frequency 24.116 +/- 0.885 ppm read ...t
Oct 08 07:36:17 computer2 systemd[1]: Started NTP client/server.
Oct 08 07:36:29 computer2 chronyd[391]: Selected source 192.33.96.102
However, I am not dual booting on this machine and I cannot remember if Fedora used ntpd in previous releases.
Reply With Quote
  #10  
Old 8th October 2013, 06:24 PM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,334
linuxfirefox
Re: System time changes every time I restart the machine.

Fedora hasn't used ntp/ntpd in a couple of releases now. Fedora now uses chrony as the replacement for ntp, and you don't want to install/enable ntp without disabling chrony. Chrony actually works better than ntp anyway, so you are better off just using it and not installing ntp.
Reply With Quote
  #11  
Old 9th October 2013, 04:32 AM
Al K D Fedora Offline
Registered User
 
Join Date: Oct 2012
Location: Australia
Posts: 5
linuxfirefox
Smile Re: System time changes every time I restart the machine.

My apology on installing ntp and ntpdate. I am just a normal user taking full precaution not to hack or break the original Fedora distribution. However, TIME is the core of any computing system and hence the Fedora team must take pride into taking ownership of the Fedora clock to ensure that it will work in all situations. For years, I have this problem, on all systems from servers to PC and notebook. I had to reset the time at the BIOS level, Windows OS and Linux on multi-boot systems after each reboot between Windows and Fedora. The following thread highlight this shameful problem.

https://wiki.archlinux.org/index.php/Time

I would not go to the extend to change the Windows Registry. Lets say that Windows, with so much of resources at its disposal, do not care. As for Fedora, the TIME problem is above a bug. It is an essential part of any Fedora distribution that must work out of the box every time without any user intervention. Can someone who knows the Fedora feature/bug process kindly contact the proper Fedora team to resolve this issue once and for all.

To elucidate why this is a problem from the user side, I came to another solution without installing ntp, but I could be wrong again.


$ sudo yum install system-config-date

$ sudo system-config-date


'system-config-date' was not install on Fedora 19 by default. I could add the ntp time source from my router.

For those who know, please be kind to correct the new procedure above for the benefit of all Fedora users.
Reply With Quote
  #12  
Old 9th October 2013, 05:03 AM
Al K D Fedora Offline
Registered User
 
Join Date: Oct 2012
Location: Australia
Posts: 5
linuxfirefox
Smile Re: System time changes every time I restart the machine.

I am now in Fedora 19.

I checked the Software packages. Under 'Admin tools', chrony.x86_64 0:1.29-1.fc19 is available, but it was not install by default. Since, I mistakenly installed ntp and ntpdate, and it seems to work, I will not do further more as it may break the integrity of the whole system. I will wait till Fedora 20 them, and I will install chrony if it is not installed by default and then install system-config-date if needed. It will be best that the Fedora team did it and that it is transparent to the users the next time.


$ timedatectl status
Local time: Wed 2013-10-09 13:39:35 EST
Universal time: Wed 2013-10-09 02:39:35 UTC
Timezone: Australia/Melbourne (EST, +1100)
NTP enabled: yes
NTP synchronized: yes
RTC in local TZ: yes
DST active: yes
Last DST change: DST began at
Sun 2013-10-06 01:59:59 EST
Sun 2013-10-06 03:00:00 EST
Next DST change: DST ends (the clock jumps one hour backwards) at
Sun 2014-04-06 02:59:59 EST
Sun 2014-04-06 02:00:00 EST

Warning: The RTC is configured to maintain time in the local time zone. This
mode is not fully supported and will create various problems with time
zone changes and daylight saving adjustments. If at all possible use
RTC in UTC, by calling 'timedatectl set-local-rtc 0'.


It seems to be working now, but I do not know if I should send the command 'timedatectl set-local-rtc 0'. I will not do anything further until the experts tell me to complete a few more steps.
Reply With Quote
  #13  
Old 9th October 2013, 05:16 AM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,334
linuxfirefox
Re: System time changes every time I restart the machine.

If you do 'timedatectl set-local-rtc 0' that will set yout system RTC to UTC instead of LOCAL time. If you are dual booting with Windows, then it will cause you problems unless you want to fight Windows and have it use UTC as well.

You still need to make sure that only one of your operating systems adjusts for daylight savings time. Windows is easy to change. It;s just a check box on the date/time settings window.
Reply With Quote
  #14  
Old 9th October 2013, 10:45 AM
slopsbucket Offline
Registered User
 
Join Date: Jul 2012
Location: Top End, Australia
Posts: 47
linuxfirefox
Re: System time changes every time I restart the machine.

Don't know if this'll help or not, I'm no guru.

Is your time being altered by the +/- hours in your timezone?

eg: a couple of years back I was playing with a few different linux's and settled on Slackware 13.37 for a while.

It wasn't an uncommon bug in Slackware for the clock to adjust itself like that at every shutdown. Some machines had system buses that Slackware didn't have proper drivers for, if it misidentified the wrong bus as a "network device" and found a clock on that bus it thought it had found UTC, every time you shut down it would reset the hardware clock back to local time. With me living at GMT+9:30 every time I rebooted the clock advanced by 9.5 hours.

There was no actual fix for the problem but there was a work-around by editing one of the boot scripts and stop it from resetting clock back to local time.

Tried a bit of googling to try and give you a link to where I found it before but had no joy. Sorry my memory's not like it used to be but maybe that will jog someone else's memory.
Reply With Quote
Reply

Tags
machine, restart, time

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] brightness settings not kept after restart - time + 2 hours OlivFedora Hardware & Laptops 8 13th November 2012 04:30 PM
A n00bs question on Backup and Restore - Time Machine / System Restore wise (!!) padre_e Gamers' Lounge 3 25th August 2010 03:18 PM
The system date and time is changing automatically, even after I set the correct time siva Using Fedora 8 31st July 2010 04:07 PM
system hangs from time to time..... chicom9 Using Fedora 2 4th December 2007 10:05 AM
How to set the System time /CMOS time using C ? kolichina_s_s Programming & Packaging 1 25th May 2006 02:11 PM


Current GMT-time: 05:22 (Sunday, 23-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Kafr Qasim Photos on Instagram - Madukkur Travel Photos - Marseille 04 Travel Photos